通过系统自带的远程桌面连接到服务器时提示“身份验证错误,要求的函数不受支持”

通过系统自带的远程桌面连接到服务器,无法正常连接,并提示:身份验证错误。要求的函数不受支持。这是由于CredSSP加密Oracle修正的原因。

 

解决方案:

方案一:修改组策略设置(适用于Windows专业版以上)

 

按“Win+R”,打开运行,输入gpedit.msc后,回车;

 

 

依次选择“管理模板-系统-凭据分配-加密Oracle修正”,双击此选项,改为已启用,并将保护级别设置为易受攻击,确定后退出。

 

 

 

重要提示:安装,卸载更新,更改机器默认设置前,请注意备份全盘重要数据。

 

方案二:删除卸载更新(适用于Windows 10家庭版)

 

Windows 10家庭版,卸载KB4103727和KB4131372两个补丁包即可。

 

在控制面板的卸载程序-查看已安装的更新中,选择要卸载的更新卸载即可。

 

 

补丁包需要逐个卸载,等第一个卸载完再卸载第二个,两个都卸载完毕后,重启电脑。

 

重要提示:安装,卸载更新,更改机器默认设置前,请注意备份全盘重要数据。

 

方案三 :安装补丁(此方案仅供参考,在更新说明中有修复了在连接到远程桌面服务器时可能会导致错误的问题。)

 

本地电脑和服务器端都同时安装更新补丁,更新以后重启服务器。

发表评论

电子邮件地址不会被公开。